ncbi-blast+: Fix perms on installed files
authorJason W Bacon <bacon@NetBSD.org>
Tue, 27 Mar 2018 17:30:22 +0000 (12:30 -0500)
committerJason W Bacon <bacon@NetBSD.org>
Tue, 27 Mar 2018 17:30:22 +0000 (12:30 -0500)
ncbi-blast+/distinfo
ncbi-blast+/patches/patch-src_build-system_Makefile.in.top

index 02f06d077bec982d99546daf7a223f28d7e1bf5d..92229cd1d8ecf3fea3fec2d0c03ca100b21322f1 100644 (file)
@@ -6,6 +6,6 @@ SHA512 (ncbi-blast-2.7.1+-src.tar.gz) = e4b3914f51165ae4c82051068ed9d3470687a4e0
 Size (ncbi-blast-2.7.1+-src.tar.gz) = 23254824 bytes
 SHA1 (patch-compilers_xcode30__prj_configure) = d6bf60c1a12ef1ddd93af1bce87543a1d5156bea
 SHA1 (patch-src_algo_blast_core_blast__kappa.c) = 0d0492bbb93d9ac48a9456bb5762c923ae84ffb9
-SHA1 (patch-src_build-system_Makefile.in.top) = 6e263f9eb1ba2a1b00a76ca0201e608531826d7b
+SHA1 (patch-src_build-system_Makefile.in.top) = 71d5246867a8c985c1175c338fb0af664094ca01
 SHA1 (patch-src_build-system_cmake_cmake-configure) = e120568c934342c8003f89470d78b28f87ae48c4
 SHA1 (patch-src_build-system_configure) = cd2cffb73da34806c189f871799960f78a1a5a4d
index 54f8202361a11057a98d9d9f0835dbdd2b45053e..cfc7e09738b98b468143f1c22c94083307d36d31 100644 (file)
@@ -1,10 +1,10 @@
 $NetBSD$
 
-# Add destdir support
+# Add destdir suppot and fix perms on installed files
 
---- src/build-system/Makefile.in.top.orig      2018-03-27 13:10:52.497034627 +0000
+--- src/build-system/Makefile.in.top.orig      2017-02-01 16:52:02.000000000 +0000
 +++ src/build-system/Makefile.in.top
-@@ -37,21 +37,21 @@ check: $(PROJECTS)
+@@ -37,22 +37,26 @@ check: $(PROJECTS)
        fi
  
  install-toolkit:
@@ -14,7 +14,7 @@ $NetBSD$
 -      $(INSTALL) -m 644 $(llibdir)/*.* $(libdir)
 +      -$(RMDIR) $(DESTDIR)$(pincludedir)
 +      $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(pincludedir)
-+      $(INSTALL) $(lbindir)/* $(DESTDIR)$(bindir)
++      $(INSTALL) -m 755 $(lbindir)/* $(DESTDIR)$(bindir)
 +      $(INSTALL) -m 644 $(llibdir)/*.* $(DESTDIR)$(libdir)
        if test -d $(llibdir)/ncbi; then \
 -          cp -pPR $(llibdir)/ncbi $(libdir)/; \
@@ -27,10 +27,15 @@ $NetBSD$
            for x in *.a; do \
                $(LN_S) "$$x" "`$(BASENAME) \"$$x\" .a`-static.a"; \
            done
++      find $(DESTDIR)$(libdir) -name '*.a' -exec chmod 644 '{}' \;
++      find $(DESTDIR)$(libdir) -name '*.so*' -exec chmod 755 '{}' \;
        for d in $(includedir0) $(incdir); do \
            cd $$d && find * -name .svn -prune -o -print | \
 -                cpio -pd $(pincludedir) ; \
 +                cpio -pd $(DESTDIR)$(pincludedir) ; \
        done
++      find $(DESTDIR)$(pincludedir) -type f -exec chmod 644 '{}' \;
++      find $(DESTDIR)$(pincludedir) -type d -exec chmod 755 '{}' \;
  ## set up appropriate build and status directories somewhere under $(libdir)?
  
+ install-gbench: