htop-git: Sync with upstream changes
authorSanthosh Raju <fox@NetBSD.org>
Tue, 9 Jan 2024 13:03:47 +0000 (14:03 +0100)
committerSanthosh Raju <fox@NetBSD.org>
Tue, 9 Jan 2024 13:05:40 +0000 (14:05 +0100)
- Fixes the NetBSD build errors and warnings.

htop-git/Makefile
htop-git/distinfo
htop-git/patches/patch-netbsd_NetBSDMachine.c [deleted file]
htop-git/patches/patch-netbsd_NetBSDProcess.c [deleted file]
htop-git/patches/patch-netbsd_NetBSDProcessTable.c [deleted file]

index ef6585e2b9999b6c0265cf847f5a1eda0f12010f..48c9ddd6e8a7eef639b09d9444a8324853fbf0d8 100644 (file)
@@ -1,10 +1,10 @@
 # $NetBSD$
 
-DISTNAME=      htop-3.2.2.20240101
+DISTNAME=      htop-3.2.2.20240109
 CATEGORIES=    sysutils
 MASTER_SITES=  ${MASTER_SITE_GITHUB:=htop-dev/}
 GITHUB_PROJECT=        htop
-GITHUB_TAG=     c3b4a770c02c28662980014b5a893e01451ec2b2
+GITHUB_TAG=     f9fb93aaf8712934ee0c78d5d887882fd29b6e36
 
 MAINTAINER=    fox@NetBSD.org
 HOMEPAGE=      https://htop.dev/
index 8e7fc92accb4dce323683e457b001cc2ce16bf3f..424af2554d9f8ee5d57d4415bface117e59e1a04 100644 (file)
@@ -1,8 +1,5 @@
 $NetBSD$
 
-BLAKE2s (htop-3.2.2.20240101-c3b4a770c02c28662980014b5a893e01451ec2b2.tar.gz) = 1dbc7c8e11c85d7b4b6e6616e999e0092da7c4bda7e6606bdf02a31143c5c811
-SHA512 (htop-3.2.2.20240101-c3b4a770c02c28662980014b5a893e01451ec2b2.tar.gz) = 40e4ccf1aa3b312d4bc69d2e560969cef623dd22856f14fd54b0ecbaf51ac8e6d96a594848d25f6081c150c091e09fe979fd1993430cdaaa1006e9a40cc99bfb
-Size (htop-3.2.2.20240101-c3b4a770c02c28662980014b5a893e01451ec2b2.tar.gz) = 405036 bytes
-SHA1 (patch-netbsd_NetBSDMachine.c) = c963b30a1b34d86409a913a55f5b51e483e70e2d
-SHA1 (patch-netbsd_NetBSDProcess.c) = 498fb3f92ef7b42bf28c2705b69e2058523d9a7e
-SHA1 (patch-netbsd_NetBSDProcessTable.c) = 6edce0026f026a0b68952321d38f906ce20e912f
+BLAKE2s (htop-3.2.2.20240109-f9fb93aaf8712934ee0c78d5d887882fd29b6e36.tar.gz) = e016ac322736b5809959e20bd74ea083d3973aeb6d726a7abe93046da8811be2
+SHA512 (htop-3.2.2.20240109-f9fb93aaf8712934ee0c78d5d887882fd29b6e36.tar.gz) = a1234b6ddbd9c55be3ed383c0618ba352d41527034f07a8e1d13df16fc11efbc884ab059ea3b6bcac3a8e330113a6cc45efdf732b9494a86a6d7130d12b87007
+Size (htop-3.2.2.20240109-f9fb93aaf8712934ee0c78d5d887882fd29b6e36.tar.gz) = 405112 bytes
diff --git a/htop-git/patches/patch-netbsd_NetBSDMachine.c b/htop-git/patches/patch-netbsd_NetBSDMachine.c
deleted file mode 100644 (file)
index a0c4ac7..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-$NetBSD$
-
-Fix build due to upstream changes.
-
-https://github.com/htop-dev/htop/pull/1360
-
---- netbsd/NetBSDMachine.c.orig        2023-12-29 15:52:13.000000000 +0000
-+++ netbsd/NetBSDMachine.c
-@@ -81,7 +81,7 @@ static void NetBSDMachine_updateCPUcount
-    }
-    if (value != super->existingCPUs) {
--      opl->cpuData = xReallocArray(this->cpuData, value + 1, sizeof(CPUData));
-+      this->cpuData = xReallocArray(this->cpuData, value + 1, sizeof(CPUData));
-       super->existingCPUs = value;
-       change = true;
-    }
-@@ -127,7 +127,7 @@ Machine* Machine_new(UsersTable* usersTa
-       CRT_fatalError("kvm_openfiles() failed");
-    }
--   return this;
-+   return super;
- }
- void Machine_delete(Machine* super) {
-@@ -268,11 +268,11 @@ static void NetBSDMachine_scanCPUFrequen
- void Machine_scan(Machine* super) {
-    NetBSDMachine* this = (NetBSDMachine*) super;
--   NetBSDProcessTable_scanMemoryInfo(this);
--   NetBSDProcessTable_scanCPUTime(this);
-+   NetBSDMachine_scanMemoryInfo(this);
-+   NetBSDMachine_scanCPUTime(this);
-    if (super->settings->showCPUFrequency) {
--      NetBSDProcessTable_scanCPUFrequency(npl);
-+      NetBSDMachine_scanCPUFrequency(this);
-    }
- }
diff --git a/htop-git/patches/patch-netbsd_NetBSDProcess.c b/htop-git/patches/patch-netbsd_NetBSDProcess.c
deleted file mode 100644 (file)
index 254cb59..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-$NetBSD$
-
-Fix build due to upstream changes.
-
-https://github.com/htop-dev/htop/pull/1360
-
---- netbsd/NetBSDProcess.c.orig        2023-12-29 15:52:13.000000000 +0000
-+++ netbsd/NetBSDProcess.c
-@@ -237,7 +237,7 @@ static void NetBSDProcess_rowWriteField(
-    switch (field) {
-    // add NetBSD-specific fields here
-    default:
--      Process_writeField(np->super, str, field);
-+      Process_writeField(&np->super, str, field);
-       return;
-    }
diff --git a/htop-git/patches/patch-netbsd_NetBSDProcessTable.c b/htop-git/patches/patch-netbsd_NetBSDProcessTable.c
deleted file mode 100644 (file)
index 5dfa2a2..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-$NetBSD$
-
-Fix build due to upstream changes.
-
-https://github.com/htop-dev/htop/pull/1360
-
---- netbsd/NetBSDProcessTable.c.orig   2023-12-29 15:52:13.000000000 +0000
-+++ netbsd/NetBSDProcessTable.c
-@@ -151,7 +151,7 @@ static double getpcpu(const NetBSDMachin
- }
- static void NetBSDProcessTable_scanProcs(NetBSDProcessTable* this) {
--   const Machine* host = this->super.host;
-+   const Machine* host = this->super.super.host;
-    const NetBSDMachine* nhost = (const NetBSDMachine*) host;
-    const Settings* settings = host->settings;
-    bool hideKernelThreads = settings->hideKernelThreads;
-@@ -182,7 +182,7 @@ static void NetBSDProcessTable_scanProcs
-          ProcessTable_add(&this->super, proc);
-          proc->tty_nr = kproc->p_tdev;
--         const char* name = ((dev_t)kproc->p_tdev != KERN_PROC_TTY_NODEV) ? devname(kproc->p_tdev, S_IFCHR) : NULL;
-+         const char* name = devname(kproc->p_tdev, S_IFCHR);
-          if (!name) {
-             free(proc->tty_name);
-             proc->tty_name = NULL;